Americable - (IW) Outage – Cable MAC 102 | BLD 1, 330, 335, 410, 411 – Incident details
Report an issue
Get updates
Email
Report an issue
Get updates
All systems operational
(IW) Outage – Cable MAC 102 | BLD 1, 330, 335, 410, 411
Resolved
Partial outage
Started 7 days ago
Lasted about 1 hour
Affected
Internet
Partial outage from 4:08 AM to 5:04 AM
Iwakuni
Partial outage from 4:08 AM to 5:04 AM
Updates
Resolved
February 05, 2026 at 5:04 AM
Resolved
February 05, 2026 at 5:04 AM
This incident has been resolved.
Investigating
February 05, 2026 at 4:08 AM
Investigating
February 05, 2026 at 4:08 AM
We are currently investigating this incident.